Welcome to AutoCAD® 2000, a product with a rich and unique history. First released in 1982 under the name MicroCAD, the first AutoCAD ran under the CP/M operating system on Intel 8080 computers. That first AutoCAD release started a revolution in drafting and design. Today, AutoCAD is translated into 18 languages and used by millions of users worldwide on computers a thousand times more powerful than those early 8080 microprocessors.

AutoCAD 2000 continues the AutoCAD heritage, and this User’s Guide is the key to its power. In this chapter you will find descriptions of new features and resources available to help you learn to use AutoCAD 2000.
What’s New in AutoCAD 2000

AutoCAD 2000 provides many new features that improve and enhance AutoCAD. This section gives a quick summary of new features and lists references to topics where you can learn more.

Heads-Up Design Environment

Heads-up Design™ means you focus on the design, not on the keyboard. AutoCAD 2000 provides new tools to help you make the most of your legacy design data, reducing the time you spend accessing and reworking similar designs. Other features simplify how you work, making AutoCAD more transparent and easier to use.

<table>
<thead>
<tr>
<th>Feature</th>
<th>What’s new?</th>
<th>For more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple document environment</td>
<td>Work with multiple drawings in a single AutoCAD session and copy, move, and paint objects, plus associated data, between them.</td>
<td>See “Working with Multiple Drawings” on page 55.</td>
</tr>
<tr>
<td>AutoCAD DesignCenter™</td>
<td>Use the new AutoCAD DesignCenter to locate and load content, such as blocks, layers, and named objects, into your drawings.</td>
<td>See chapter 14, “Managing Content with AutoCAD DesignCenter.”</td>
</tr>
<tr>
<td>Quick dimensions</td>
<td>Use the new QDIM command to automatically create any number of dimensions with a simple selection of geometry.</td>
<td>See “Dimensioning Multiple Objects” on page 405.</td>
</tr>
<tr>
<td>New object snaps</td>
<td>Use the new Parallel and Extension object snaps to draw more precisely.</td>
<td>See “Parallel” on page 176 and “Extension” on page 177.</td>
</tr>
<tr>
<td>AutoTrack™</td>
<td>Use polar and object snap tracking to create objects at specific polar angles or at angles relative to object snap points.</td>
<td>See “Using AutoTrack” on page 178.</td>
</tr>
<tr>
<td>Partial open and partial load</td>
<td>Open and edit only needed portions of drawings and Xrefs.</td>
<td>See “Using Partial Open and Partial Load” on page 311.</td>
</tr>
<tr>
<td>Real-time 3D rotation</td>
<td>Use the new 3DORBIT command to easily manipulate views of 3D objects.</td>
<td>See “Interactive Viewing in 3D” on page 601.</td>
</tr>
</tbody>
</table>
### Heads-up design environment (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>What’s new?</th>
<th>For more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple active work planes</td>
<td>Viewports and views can have different user coordinate system (UCS) and elevation settings, which makes working in 3D easier.</td>
<td>See “Working with UCSs in Viewports” on page 117 and “Working with Views in 3D” on page 596.</td>
</tr>
<tr>
<td>UCS Manager</td>
<td>Manage your UCSs using the new UCS Manager dialog box.</td>
<td>See “Saving and Restoring a Named UCS” on page 118 and “Working with Views in 3D” on page 596.</td>
</tr>
<tr>
<td>View</td>
<td>Manage views using the new View dialog box.</td>
<td>See “Working with Views in 3D” on page 596.</td>
</tr>
<tr>
<td>Reference editing</td>
<td>Edit external references and block references from within your current drawing.</td>
<td>See “Editing References in Place” on page 484.</td>
</tr>
<tr>
<td>Toolbars</td>
<td>Use AutoCAD toolbars that are enhanced to conform to Microsoft® Office 98 standards.</td>
<td>See “Working with Toolbars” on page 58.</td>
</tr>
</tbody>
</table>

### Improved Access and Usability

The AutoCAD 2000 interface is more design-centric and less command-centric, making the software more transparent in the design process.

<table>
<thead>
<tr>
<th>Improved access and usability</th>
<th>Feature</th>
<th>What’s new?</th>
<th>For more information</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Properties window</td>
<td>Modify the properties of an object in a drawing quickly and easily.</td>
<td>See “Using the Properties Window” on page 260.</td>
</tr>
<tr>
<td></td>
<td>Object Properties toolbar</td>
<td>Use convenient new methods for editing common object properties such as lineweight and plot style.</td>
<td>See “Using the Object Properties Toolbar” on page 250.</td>
</tr>
<tr>
<td></td>
<td>IntelliMouse</td>
<td>Use the Microsoft IntelliMouse® including IntelliMouse panning and zooming.</td>
<td>See “IntelliMouse” on page 63.</td>
</tr>
<tr>
<td></td>
<td>Quick Select</td>
<td>Use Quick Select to select objects based on object type or object properties.</td>
<td>See “Filtering Selection Sets” on page 238.</td>
</tr>
<tr>
<td>Feature</td>
<td>What’s new?</td>
<td>For more information</td>
<td></td>
</tr>
<tr>
<td>-----------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Shortcut menus</td>
<td>Right-click your pointing device to display new shortcut menus to access AutoCAD commands.</td>
<td>See “Using Shortcut Menus” on page 59.</td>
<td></td>
</tr>
<tr>
<td>Solids editing</td>
<td>You can manipulate your 3D solid models without creating new geometry or performing Boolean operations.</td>
<td>See “Editing Faces of 3D Solids” on page 648.</td>
<td></td>
</tr>
<tr>
<td>Summary information</td>
<td>Store drawing information, such as title, subject, author, keywords, and ten custom fields.</td>
<td>See “Viewing and Updating Drawing Properties” on page 86.</td>
<td></td>
</tr>
<tr>
<td>Text editing</td>
<td>Use the new text-control capabilities of the Multiline Text Editor to edit text more quickly.</td>
<td>See “Using Multiline Text” on page 353 and “Formatting Line Text” on page 349.</td>
<td></td>
</tr>
<tr>
<td>Layer Properties Manager</td>
<td>Quickly set layer properties, such as color and linetype.</td>
<td>See “Working with Layers” on page 316.</td>
<td></td>
</tr>
<tr>
<td>Long named object names</td>
<td>The 31-character limit has been removed. Named object names can have up to 255 characters and include more special characters, including spaces.</td>
<td>See “Working with Named Objects” on page 157.</td>
<td></td>
</tr>
<tr>
<td>Dimension styles</td>
<td>The new Dimension Styles Manager replaces the DDIM dialog box so you can create and manage dimension styles quickly and effectively.</td>
<td>See “Managing Dimension Styles” on page 432.</td>
<td></td>
</tr>
<tr>
<td>Quick leader</td>
<td>Use the new QLEADER command to easily create and modify leaders.</td>
<td>See “Creating Leaders and Annotation” on page 412.</td>
<td></td>
</tr>
<tr>
<td>Load/Unload applications</td>
<td>The new Load/Unload Applications dialog box makes loading and unloading applications easier and more intuitive.</td>
<td>See APPLOAD in the Command Reference.</td>
<td></td>
</tr>
<tr>
<td>Boundary hatches</td>
<td>The revised Boundary Hatch dialog box makes boundary hatch management easier.</td>
<td>See BHATCH in the Command Reference.</td>
<td></td>
</tr>
<tr>
<td>Saving drawings</td>
<td>Use the new Save Drawing As dialog box to specify the default file format in which you want to save your drawings.</td>
<td>See SAVEAS in the Command Reference.</td>
<td></td>
</tr>
</tbody>
</table>
Expanded Reach

Design is collaborative. Using the new AutoCAD Internet tools, you can dynamically create intelligent drawings linked to databases and resources around the world.

<table>
<thead>
<tr>
<th>Feature</th>
<th>What’s new?</th>
<th>For more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access files across the Web</td>
<td>Use the Web to access and store AutoCAD data with faster, more intuitive Internet access.</td>
<td>See “Opening and Saving Files from the Internet” on page 813.</td>
</tr>
<tr>
<td>Hyperlinks</td>
<td>Attach hyperlink attachments to AutoCAD objects or graphic locations, then follow them using the Attach Hyperlinks dialog box.</td>
<td>See “Working with Hyperlinks” on page 817.</td>
</tr>
<tr>
<td>ePlot</td>
<td>Create an electronic plot of a drawing (or layout) in a secure, Internet-ready, neutral file format.</td>
<td>See “Using ePlot to Publish DWF Files” on page 822.</td>
</tr>
</tbody>
</table>

Streamlined Output

AutoCAD 2000 has many new features and improvements to give you greater flexibility and control of your output. You can create nonrectangular viewports and assign lineweights to objects for your output.

<table>
<thead>
<tr>
<th>Feature</th>
<th>What’s new?</th>
<th>For more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layouts</td>
<td>Compose a drawing and quickly prepare it for plotting.</td>
<td>See chapter 15, “Creating a Layout to Plot.”</td>
</tr>
<tr>
<td>Nonrectangular viewports</td>
<td>Create irregular-shaped viewports by selecting objects or points in the drawing area.</td>
<td>See “Creating Nonrectangular Viewports” on page 542.</td>
</tr>
<tr>
<td>Lineweight</td>
<td>Use the new lineweight property to add width to your objects in the drawing area and in printed drawings.</td>
<td>See “Working with Lineweights” on page 339.</td>
</tr>
<tr>
<td>Plotting</td>
<td>Use new wizards and editors that make plotting easier.</td>
<td>See chapter 16, “Plotting Your Drawings.”</td>
</tr>
</tbody>
</table>
ActiveX® has several new objects, including MenuBar, MenuGroups, PopupMenus, and Toolbars. Application-, document-, and object-level events are now available. See the *ActiveX and VBA Developer’s Guide* for introductory material concerning these objects and events.

In Microsoft Visual Basic® for Applications (VBA), you can now reference a project from another project. You can also create libraries of common functions and macros. See “Getting Started with AutoCAD VBA” in the *ActiveX and VBA Developer’s Guide*.

### Learning AutoCAD

Many resources are available to help you learn to use AutoCAD. The AutoCAD documentation suite includes printed and online manuals covering a wide range of topics. AutoCAD 2000 Learning Assistance™ provides multimedia training on AutoCAD. You can also attend AutoCAD training classes through the Autodesk Training Centers.

### Online Documentation

You can view the online documentation for AutoCAD by selecting AutoCAD Help from the Help menu. Online documentation is divided into two groups. User documentation, which is displayed first, includes the following:

- *AutoCAD 2000 Readme:* Provides last-minute changes or additions to AutoCAD 2000.
- *Using AutoCAD Help:* Provides tips and techniques for using the online AutoCAD Help.
• **Command Reference:** Provides a comprehensive reference to all AutoCAD commands and system variables.
• **User’s Guide:** Explains AutoCAD concepts and provides step-by-step procedures. Includes a glossary with definitions of AutoCAD terms.
• **Installation Guide:** Tells you how to install and configure AutoCAD 2000.
• **Customization Guide:** Tells experienced users how to customize AutoCAD.
• **Plotting With AutoCAD:** Provides a list of topics specific to plotting and plotting drivers.

Selecting either the Visual LISP or the VBA and ActiveX book icon displays a shortcut that takes you to the AutoCAD developer documentation:

• **AutoLISP Reference:** Provides a comprehensive reference for AutoLISP®, a full-featured interpretive programming language, which you can use to call AutoCAD commands, system variables, and dialog boxes.
• **Visual LISP Developer’s Guide:** Provides information for using the Visual LISP™ interactive development environment to develop and test AutoLISP programs. Also describes how to use the AutoLISP extensions provided with Visual LISP to create ActiveX automations.
• **Visual LISP Tutorial:** Provides step-by-step lessons that teach you how to use Visual LISP to develop an AutoLISP application.
• **ActiveX and VBA Developer’s Guide:** Explains how to use ActiveX and VBA to develop an application to customize AutoCAD. Includes sample code and step-by-step procedures.
• **ActiveX and VBA Reference:** Provides a reference to the ActiveX object model and its associated interface components.
• **DXF Reference:** Provides a comprehensive reference to the DXF file format.

**Printed Manuals**

AutoCAD includes two printed manuals and a reference card:

• **Installation Guide:** The same content as the online Installation Guide, except in printed format.
• **User’s Guide:** The same content as the online User’s Guide, except in printed format.
• **Quick Reference Card:** An at-a-glance reference to AutoCAD toolbars and accelerator keys. The card is located at the back of the printed User’s Guide but is not available online.
You can order printed copies of the following AutoCAD manuals from Autodesk or your authorized Autodesk dealer or reseller:

- Command Reference
- Customization Guide
- Visual LISP Developer’s Guide
- Visual LISP Tutorial
- ActiveX and VBA Developer’s Guide

AutoCAD 2000 Learning Assistance

AutoCAD 2000 Learning Assistance, provided on a separate CD, is a multimedia learning tool that focuses on working in AutoCAD, understanding difficult concepts and underutilized AutoCAD features, and collaborating with other AutoCAD professionals.

AutoCAD Training

Autodesk® Official Training Courseware (AOTC) is the Autodesk-endorsed courseware for instructor-led training. To register for a training course using this courseware, contact an Authorized Autodesk Training Center, Authorized Autodesk Reseller, or Autodesk System Center. You can find a list of these organizations on the Autodesk Technical Assistance Web site (http://www.autodesk.com/support).

Migrating to AutoCAD 2000

AutoCAD 2000 Migration Assistance provides information and tools to help you migrate from previous versions of AutoCAD. You can use AutoCAD 2000 Migration Assistance to migrate your custom applications, menus, toolbars, and drawings to AutoCAD 2000. For example, the AutoLISP Code Analyzer reviews your AutoLISP applications and the Batch Drawing Converter helps you migrate drawing files created in earlier releases to AutoCAD 2000. You can start AutoCAD 2000 Migration Assistance from the Start menu (Windows). If you have not already installed AutoCAD 2000 Migration Assistance, see chapter 2, “Installing AutoCAD for an Individual User,” in the Installation Guide.
Getting Technical Support

To complement the technical support provided by your AutoCAD dealer or reseller, you can find technical support information from the following sources:

- **AutoCAD Support Assistance**: Provides technical support information about AutoCAD. Accessed from the Help menu, you can look up technical solutions by title or by category, or use the search tool to look for solutions by keyword. The AutoCAD Support Assistance knowledge base also contains information about other support resources and self-help tools to help you get the most out of AutoCAD.
- **Autodesk Product Support Services**: Provides Web-based technical support for Autodesk products. See “Autodesk on the Web” on page 43.

Where to Start

The *User’s Guide* explains concepts and provides step-by-step procedures for completing common drafting tasks. The glossary will help familiarize you with AutoCAD terminology. The Quick Reference card can serve as a handy reminder of common selection and input methods.

As you gain experience, you can learn more about specific commands and options by referring to the *Command Reference*.

Once you gain some proficiency with AutoCAD, you can use the *Customization Guide* to learn how to customize AutoCAD and develop specialized capabilities.

To increase your knowledge and productivity, choose Learning Assistance on the AutoCAD Help menu. These tutorials will help you work more efficiently with AutoCAD 2000, teach you about difficult and less well known AutoCAD features, and show you how to collaborate with others by sharing designs across the Internet.

Getting Help

At any time during an AutoCAD session, you can access online information from the Help menu. Use the Help topics for assistance as you work. See Using AutoCAD Help in the Help topics for information about using the AutoCAD Help system efficiently.
To access Help topics

- From the Help menu, choose AutoCAD Help Topics.

The Contents tab displays the online versions of the AutoCAD documentation suite, as well as other information. Use the Index tab to search for terms and topics in the online index; use the Find tab to conduct full text searches.

**Command line**  
HELP

**Related**  
Press F1 or enter ? on the command line.

## Typographical Conventions

To orient you to AutoCAD features as they appear on the screen, specific terms are set in typefaces that distinguish them from the body text. Throughout AutoCAD documentation, the following conventions are used.

<table>
<thead>
<tr>
<th>Typographical conventions</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text element</strong></td>
<td></td>
</tr>
<tr>
<td>AutoCAD commands</td>
<td>ADCENTER, DBCONNECT, SAVE</td>
</tr>
<tr>
<td>AutoCAD system variables</td>
<td>DIMBLK, DWGNAME, LTSCALE</td>
</tr>
<tr>
<td>AutoCAD named-objects, such as linetypes and styles</td>
<td>DASHDOT, STANDARD</td>
</tr>
<tr>
<td><strong>Prompts</strong></td>
<td>Select object to trim or [Project/Edge/Undo]:</td>
</tr>
</tbody>
</table>
| **Instructions after prompt sequences** | Select objects:  
Use an object selection method |
| File names and file name extensions | acad.exe, Readme file, .dwg file extension |
| **Folder or directory names** | Sample folder, c:\ACAD2000\support |
| **Text you enter** | At the Command prompt, enter shape. |
| **Keys you press on the keyboard** | CTRL, F10, ESC, ENTER |
| **Keys you press simultaneously on the keyboard** | CTRL + C |
| **AutoLISP variable names, sample code, and text in ASCII files** | The variable \( \pi \) is preset to a value of \( \pi \) |
| **AutoLISP and DIESEL function names** | command ads_command( ) |
| **Formal arguments specified in function definitions** | The \textit{string} and \textit{mode} arguments |
Additional Resources

The following resources provide additional information and assistance with your questions about AutoCAD 2000 and other Autodesk products.

Autodesk on the Web

From the AutoCAD 2000 Help menu, select Autodesk on the Web to access information and resources on the Web.

- **AutoCAD Home Page**: Displays the main AutoCAD 2000 product page. ([http://www.autodesk.com/autocad](http://www.autodesk.com/autocad))
- **AutoCAD Plug-in Store**: Displays information about AutoCAD 2000 plug-in applications created by third party developers. ([http://www.cadplugins.com](http://www.cadplugins.com))
- **AutoCAD Technical Publications**: Provides procedures for updating your online documentation. ([http://www.autodesk.com/techpubs/autocad](http://www.autodesk.com/techpubs/autocad))
- **Autodesk Home Page**: Displays the main Autodesk home page. ([http://www.autodesk.com](http://www.autodesk.com))
- **Autodesk Product Support Services**: Displays Web-based support information organized by product. ([http://www.autodesk.com/support](http://www.autodesk.com/support))
- **Autodesk Developer’s Resource Guide**: Provides information on products and services that complement Autodesk software offered by independent Autodesk Registered Developers. ([http://www.argonline.com](http://www.argonline.com))
- **Autodesk User Group International**: Displays the AUGI home page. ([http://www.augi.com](http://www.augi.com))

Receiving Information by Fax

You can receive technical and product support documents using the Autodesk FAX Information System. The phone number is 1-415-446-1919.

Contacting AutoCAD Technical Publications

AutoCAD Technical Publications welcomes your comments and suggestions about AutoCAD documentation. To contact AutoCAD Technical Publications, complete the form on the Technical Publications Web site ([http://www.autodesk.com/techpubs/autocad](http://www.autodesk.com/techpubs/autocad)), or send an email to: acad_docs@autodesk.com.
Getting Started

This chapter introduces concepts and procedures that help you get started with AutoCAD®. You learn how to open, close, and manage your drawings. You also learn about the AutoCAD window elements and how you can use them to design quickly and efficiently.
Starting AutoCAD

When you start AutoCAD, the Startup dialog box is displayed. The dialog box provides you with four ways to start a drawing. You can

- Open an existing drawing
- Start a drawing from scratch
- Start a drawing based on a template
- Use wizards to help you set up your drawing

To start AutoCAD

1. From the Start menu (Microsoft® Windows®) choose Programs. Then choose AutoCAD 2000 from the menu.

2. In the Startup dialog box, choose one of the following:
   - **Open a Drawing**: Opens a drawing you select from a list of the four most recently opened drawings. Also, displays the Browse button that you choose to look for another file. See “Opening Existing Drawings” on page 52.
   - **Start from Scratch**: Opens a new drawing based on the measurement system you choose—English (inches) or metric (millimeters). See “Starting Drawings from Scratch” on page 47.
Use a Template: Opens a new drawing based on a template you select from a list. The list displays template files (.dwt extension) that exist in the drawing template file location as specified in the Options dialog box (see OPTIONS). Template files store all the settings for a drawing and can also include predefined layers, dimension styles, and views. See “Using Templates” on page 49.

Use a Wizard: Opens a new drawing that you set up using either the Quick Setup wizard or the Advanced Setup wizard. See “Starting Drawings with Setup Wizards” on page 48.

The Startup dialog box is displayed when you first start AutoCAD. Whenever you start a new drawing during your AutoCAD session, the Create New Drawing dialog box is displayed. After you use AutoCAD for a while, you may want to turn off display of these dialog boxes. If you turn them off, choosing File ➤ New automatically creates a new drawing based on your last Start from Scratch selection (English or metric). Choosing File ➤ Open displays the Select File dialog box, where you can select AutoCAD drawings and templates.

To turn off display of the Startup dialog box

■ In the Startup dialog box, clear Show Startup Dialog.

To display the Startup dialog box

1 From the Tools menu, choose Options.
2 In the Options dialog box, choose the System tab.
3 Under General Options, select Show Startup Dialog.
4 Choose OK.

Starting Drawings from Scratch

Starting a drawing from scratch is a quick way to begin a new drawing. When you select this drawing startup method, you can select one of two measurement systems on which to base the new drawing:

■ English: Creates a new drawing based on the Imperial measurement system. The drawing is based on the acad.dwt template, and the default drawing boundary, called the drawing limits, is 12 × 9 inches.

■ Metric: Creates a new drawing based on the metric measurement system. The drawing is based on the acadiso.dwt template, and the default drawing boundary is 429 × 297 millimeters.
To create a new drawing using Start from Scratch

1 In the Startup dialog box, choose Start from Scratch. (If AutoCAD is already started, from the File menu, choose New, and then choose Start from Scratch in the Create New Drawing dialog box.)

2 Select English or Metric, and then choose OK. The drawing opens based on the English (acad.dwt) or metric (acadiso.dwt) template and with the name drawing1.dwg.

3 From the File menu, choose Save As.

4 In the Save Drawing As dialog box under File Name, enter a name for the drawing and choose Save. AutoCAD automatically appends the drawing extension (.dwg) to the new file name.

Command line  NEW

System variables  MEASUREINIT sets initial drawing units as English or metric for any new drawings. MEASUREMENT sets drawing units as English or metric for the current drawing. See “Using System Variables” on page 103.

Starting Drawings with Setup Wizards

AutoCAD setup wizards start with the same settings used when you start a drawing from scratch, that is, English or metric, then customize other settings depending on the wizard you choose.

The Quick Setup wizard sets the drawing units and drawing area. Choices for drawing units include Decimal, Engineering, Architectural, Fractional, and Scientific. You also specify the width and length of the drawing area to
establish the drawing boundary, or limits. The area within the limits is the final plotted sheet size.

With the Advanced Setup wizard, you can specify the same settings as the Quick Setup wizard (drawing units and drawing area), and you can specify several angle settings, including the angle of measurement, the direction of the zero angle, and the direction in which AutoCAD measures angles from the zero angle.

To start a drawing using a wizard

1. In the Startup dialog box, choose Use a Wizard. (If AutoCAD is already started, from the File menu, choose New, and then choose Use a Wizard in the Create New Drawing dialog box.)

2. Under Select a Wizard, select Quick Setup or Advanced Setup and choose OK.

3. Complete the wizard pages using the Next and Back buttons to move forward and backward.

4. On the last page choose Finish. The wizard starts your drawing session.

Command line NEW

Using Templates

When you start a new drawing, you can use a template (DWT) file containing settings for specific drawing purposes. You can use one of the templates supplied with AutoCAD or create your own templates. Any existing drawing can serve as a template. When you use an existing drawing as a template, all drawing settings are made in the new drawing.
Although you can save any drawing as a template, you should prepare templates to include settings and drawing elements consistent with your office or project standards, such as

- Unit type and precision
- Drawing limits
- Snap, Grid, and Ortho settings
- Layer organization
- Title blocks, borders, and logos
- Dimension and text styles
- Linetypes and lineweights

If you start a drawing from scratch, AutoCAD uses either the `acad.dwt` template (inches) or `acadiso.dwt` template (millimeters). When you create a new drawing based on an existing template and make changes, the changes in the new drawing do not affect the template.

To start a drawing using a template

1. In the Startup dialog box, choose Use a Template. (If AutoCAD is already started, from the File menu, choose New, and then choose Use a Template in the Create New Drawing dialog box.)
2. Under Select a Template, select a template from the list or choose Browse to select another file.
   A preview image of the template appears at the right, and a description appears near the bottom of the dialog box.
3. Choose OK.
   AutoCAD opens the drawing as `drawing.dwg`.

**Command line**

To create a template

1. From the File menu, choose Open.
2. In the Open dialog box, select the file you want to use as a template and choose OK.
If necessary, change settings in the drawing and add (or replace the existing) border and title block. See “Using the Layout Wizard to Specify Layout Settings” on page 515.

3 If you want to delete the existing file contents, from the Modify menu, choose Erase.

4 At the Select Objects prompt, enter all, and then select the border and title block (if you want to remove them) and enter $r$ (Remove).

5 From the File menu, choose Save As.

6 In the Save Drawing As dialog box under Save Files as Type, select the Drawing Template file type.

7 Under File Name, enter a name for the template. Choose OK.

8 In the Template Description dialog box, enter a brief description of the template.

   This description is displayed whenever you select this template in the Create New Drawing dialog box.

9 Choose OK.

   The new template is saved in the template folder.

**Recovering the Default Template**

If settings in the AutoCAD default English and metric unit templates, *acad.dwt* or *acadiso.dwt*, are changed from the original defaults, you can use the following procedure to reset them. (To use the procedure, the Startup dialog box display must be turned on. See “Starting AutoCAD” on page 46.)

To recover the default template

1 From the File menu, choose New.

2 In the Create New Drawing dialog box, select Start from Scratch, and then select one of the following:

   - English to restore *acad.dwt*
   - Metric to restore *acadiso.dwt*

3 Choose OK.

   The drawing opens with the default AutoCAD settings.

4 From the File menu, choose Save As.

5 In the Save Drawing As dialog box, select the Drawing Template file type. Save the drawing with its original name, either *acad.dwt*, or *acadiso.dwt*.

**Command line**   NEW
Opening Existing Drawings

To open an existing AutoCAD drawing, you can select Open a Drawing in the Startup dialog box or, if AutoCAD is already started, choose Open from the File menu. You can also open drawings by dragging them from Windows Explorer into AutoCAD. If you drop one or more drawings anywhere outside the drawing area, for example, the command line or the blank space next to the toolbars, AutoCAD opens the drawings. However, if you drag a single drawing into the drawing area of an open drawing, the new drawing is not opened but inserted as an external reference. See chapter 13, “Using Blocks and External References.”

You can double-click a drawing in Windows Explorer to launch AutoCAD and open the drawing. If AutoCAD is already running, the drawing opens in the current session rather than in a second session.

While opening an AutoCAD 2000 drawing, you can use the Partial Open option to work with only part of the drawing file. If you are working with a large drawing, you can partially open the drawing and select a specific view and layers to work with instead of loading the entire drawing. See “Using Partial Open and Partial Load” on page 311.

To open a drawing

1. In the Startup dialog box, choose Open a Drawing, and then choose Browse. (If AutoCAD is already started, from the File menu, choose Open.)

2. In the Select File dialog box, select one or more files and choose Open. You can also enter the drawing name under File Name and choose Open, or double-click a file name in the list of files.

Command line

OPEN
Using the Drawing Browser

Use the drawing browser to view small images of drawings, to open drawings, and to search for files. You can use the browser to search for files across multiple directories on a single drive or on multiple drives.

Browsing Through Files

The Browse/Search dialog box displays small images of drawings in the directory you specify. You can sort the images by file type, and then click an image to select it. You can change the image size by selecting an option in the Size list on the Browse tab in the Browse/Search dialog box.

To open drawings using the drawing browser

1. From the File menu, choose Open.
2. In the Select File dialog box, choose Find File.
3. On the Browse tab in the Browse/Search dialog box, select the drive and directory containing the files you want to view.
4. Under List Files of Type, select a file type to list.
5. To open a file, either double-click its image or select its image and choose Open.

Command line  OPEN
Searching for Files

You can search for files by specifying a file type and referencing the date of creation. For example, you could search for linetype (LIN) files created after 3:00 p.m. on a certain day.

To search for files

1. From the File menu, choose Open.
2. In the Select File dialog box, choose Find File.
3. In the Browse/Search dialog box, choose the Search tab.

4. On the Search tab, enter a search pattern or select a file type to search for. You can use wild cards in search patterns.
5. Under Date Filter, select a reference, for example, Before This Date or After This Date, and enter the time and date to refer to.
6. Under Search Location, specify a drive and directory path. Choose Edit to change the search path in the Edit Path dialog box.
7. Choose Search.
   - The button name changes to Stop Search. Press it to stop the search at any time.
8. When the search is completed, double-click the file you want to open in the Files list or select the file name and choose Open.
9. Choose Exit.
Working with Multiple Drawings

You can open more than one drawing in a single AutoCAD session. When multiple drawings are open, simply click anywhere in the drawing to make it active. You can also use CTRL + F6 or CTRL + TAB to switch between open drawings. However, you cannot switch between drawings during certain long operations such as regenerating the drawing. See “Refreshing the Screen Display” on page 64.

You can quickly reference other drawings, copy and paste between drawings, or drag objects from one drawing to another. You can also use the Property Painter to transfer properties from objects in one drawing to objects in another drawing. You can use AutoCAD object snaps, the Copy with Basepoint command, and the Paste to Original Coordinates command to ensure accurate placement, especially when copying objects from one drawing to another. For more information about copying objects between drawings, sessions, and other applications, see “Copying Objects” on page 266. See MATCHPROP.

Use the Window menu to control the display of multiple drawings in an AutoCAD session. You can cascade open drawings or tile them vertically or horizontally. When you have a number of drawings minimized, you can use Arrange Icons to clean up the display of the minimized drawing icons in the AutoCAD window. You can also select a drawing from the list of open drawings at the bottom of this menu.

To turn off Multiple Document mode

1. From the Tools menu, select Options.
2. On the System tab under General Options, select Single Drawing Compatibility mode. Choose OK.

System variables  SDI sets Multiple Document mode.

Understanding the AutoCAD Window

When you start AutoCAD, the AutoCAD window opens. The window is your design work space. It contains elements that you use to create your designs and to receive information about them. The following illustration shows the main parts of the AutoCAD window.
Chapter 2  Getting Started

Menu Bar
Contains the default AutoCAD menus. Menus are defined by menu files that you can modify or design on your own. See chapter 4, “Custom Menus,” in the Customization Guide. Additionally, installing third-party applications may add menus or menu commands. The default menu file is acad.mnu. To learn how to specify a different one, see “Specifying Search Paths, File Names, and File Locations” on page 74.

Standard Toolbar
Contains frequently used buttons such as Redraw, Undo, and Zoom, as well as Microsoft Office standard buttons such as Open, Save, Print, and Spell. Buttons with small black triangles in the lower-right corner have flyouts containing tools that invoke commands related to the first tool shown. Click and hold down the first button to display the flyout.

Drawing File Icon
Represents a drawing file in AutoCAD. The drawing file icon is also displayed next to options in dialog boxes that are saved in the drawing, instead of in each session as in AutoCAD.
<table>
<thead>
<tr>
<th>Object Properties Toolbar</th>
<th>Sets object properties such as color, linetype, and line-weight and manages layers. See “Using the Object Properties Toolbar” on page 250.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw and Modify Toolbars</td>
<td>Provide access to common draw and modify commands. The Draw and Modify toolbars are displayed when you start AutoCAD. These toolbars are docked on the left side of the window. You can easily move toolbars and turn them on and off. See “Working with Toolbars” on page 58.</td>
</tr>
<tr>
<td>Drawing Area</td>
<td>Displays drawings. The drawing area size varies, depending on the size of the AutoCAD window and on the number of other elements (such as toolbars and dialog boxes) that are displayed.</td>
</tr>
<tr>
<td>Crosshairs</td>
<td>Identifies pick and drawing points within the drawing area. Use the crosshairs, which are controlled by your pointing device, to locate points and select and draw objects.</td>
</tr>
<tr>
<td>User Coordinate System (UCS) Icon</td>
<td>Shows the orientation of the drawing. AutoCAD drawings are superimposed on an invisible grid, or coordinate system. Coordinate systems are based on X, Y, and (for 3D) Z coordinates. AutoCAD has a fixed world coordinate system (WCS) and a movable user coordinate system (UCS). To help you visualize the UCS location and orientation, a UCS icon is displayed in the lower-left corner of the drawing area. See chapter 5, “Using Coordinate Systems.”</td>
</tr>
<tr>
<td>Model Tab/Layout Tabs</td>
<td>Switch your drawing between model (drawing) space and paper (layout) space. You generally create your designs in model space, and then create layouts to plot and print your drawing in paper space. See chapter 15, “Creating a Layout to Plot.”</td>
</tr>
</tbody>
</table>
| Command Window            | Displays prompts and messages. In AutoCAD, you start commands in one of three ways:  
  - Choose an item from a menu or a shortcut menu.  
  - Click a button on a toolbar.  
  - Enter the command on the command line.  

However, even if you choose commands from menus and toolbars, AutoCAD may display command prompts and the command history in a command window. See chapter 4, “Using Commands and System Variables.”
Status Bar
Displays the cursor coordinates in the lower-left corner. The status bar also contains buttons that you can use to turn on common drawing aids. These include Snap (Snap mode), Grid (drawing grid), Ortho (Ortho mode), Polar (polar tracking), Osnap (object snaps), Otrack (object snap tracking), Lwt (lineweight display), and Model (model and paper space toggle). See chapter 7, “Drawing with Precision,” for more information about AutoCAD drawing aids.

Working with Toolbars

AutoCAD provides 24 toolbars for access to frequently used commands, settings, and modes. The Standard, Object Properties, Draw, and Modify toolbars are displayed by default.

To display or close toolbars
1. Right-click the background or title bar of any displayed toolbar, such as the Standard or Draw toolbar.
2. From the shortcut menu, select the toolbar you want to display or close.

Command line TOOLBAR displays the Toolbars dialog box, in which you can turn toolbars on and off and customize toolbars. See “Modifying Toolbars” on page 88.

You can display multiple toolbars at once, and you can dock or float toolbars. Docked toolbars lock into place along the top, bottom, or sides of the AutoCAD window. Floating toolbars move freely; move them using your pointing device. Floating toolbars can overlap other floating and docked toolbars. You can also hide toolbars until you need them.

To dock or undock a toolbar
1. To dock a toolbar, place your pointer on the background or title bar of the toolbar, then use your pointing device to drag the toolbar to a dock location at the top, bottom, or either side of the drawing window.
2. When the outline of the toolbar appears in the docking area you want, release the pointing device button.
3. To undock a toolbar, drag it outside the docking region.
4. To place a toolbar in a docking region without docking it, hold down CTRL as you drag.
To change the shape of a floating toolbar

- Drag the bottom border of a floating toolbar to create a vertical toolbar.  
  or
- Drag the side border of a floating toolbar to create a horizontal toolbar.  
  or
- Drag the border of a floating toolbar to reshape it.

**NOTE** You cannot change the shape of docked toolbars.

### Using Shortcut Menus

You can right-click your pointing device to display shortcut menus from which you can quickly choose options. See “Using Pointing Devices” on page 62 for information about how to right-click each pointing device. On some keyboards, you can display shortcut menus by pressing the Shortcut Menu key.

Shortcut menus are context-sensitive. The shortcut menu that is displayed, and the options it provides, depend on the pointer location and other conditions, such as whether an object is selected or a command is in progress. You can display shortcut menus from most of the following AutoCAD window areas:

- Drawing area
- Command line
- Dialog boxes and windows (for example, AutoCAD DesignCenter™)
- Toolbars
- Status bar
- Model tab and layout tabs

### Using Shortcut Menus in the Drawing Area

Right-clicking in the drawing area displays one of six shortcut menus: Default, Edit, Command, Object Snap, Hot Grips, or OLE. You can control the display of Default, Edit, and Command menus from the User Preferences tab in the Options dialog box. See “Controlling Default, Edit, and Command Shortcut Menus” on page 60. For information about additional shortcut menus, see “Using Shortcut Menus Outside the Drawing Area” on page 62.
The following table describes how to access the shortcut menus that are displayed when you right-click in the drawing area.

<table>
<thead>
<tr>
<th>Shortcut menu</th>
<th>Access and contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Deselect all objects, end any active command, and right-click for a shortcut menu with common options such as Copy, Paste, Pan, and Zoom.</td>
</tr>
<tr>
<td>Edit</td>
<td>Select one or more objects, end any active command, and right-click for a shortcut menu with options for editing objects. The shortcut menu may contain options specific to the kind of object selected.</td>
</tr>
<tr>
<td>Command</td>
<td>Start a command and, while the command is active, right-click for a shortcut menu with options that are useful when a command is in progress. The shortcut menu also includes any options currently displayed in a prompt on the command line.</td>
</tr>
<tr>
<td>Object Snap</td>
<td>Press SHIFT while you right-click for a shortcut menu that provides access to the object snaps, object snap settings, and point filters.</td>
</tr>
<tr>
<td>Hot Grips</td>
<td>Select a grip on an object, and then right-click for grip editing options.</td>
</tr>
<tr>
<td>OLE</td>
<td>Right-click an OLE object for options that are useful for editing OLE objects.</td>
</tr>
</tbody>
</table>

**Controlling Default, Edit, and Command Shortcut Menus**

The Object Snap, Hot Grips, and OLE shortcut menus are always turned on. However, you can control the display of the Default, Edit, and Command shortcut menus. When you turn off these menus, right-clicking in the drawing area is the same as pressing ENTER. By default, all three menu types are turned on.

**To turn off shortcut menus in the drawing area**

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the User Preferences tab.
4. To control Default, Edit, and Command shortcut menus individually, select Shortcut Menus in Drawing Area, and then choose Right-Click Customization.

5. In the Right-Click Customization dialog box under Default Mode or Edit Mode, select one of the following options to control what happens when you right-click in the drawing area and no command is in progress:

- **Repeat Last Command**: Repeats the last command. Selecting this option turns off the Default and Edit shortcut menus. Right-clicking is the same as pressing ENTER.
- **Shortcut Menu**: Displays the Default or Edit shortcut menu.

6. Under Command Mode, select one of the following options to determine what happens when you right-click in the drawing area while a command is in progress:

- **Enter**: Turns off the Command shortcut menu. Right-clicking is the same as pressing ENTER.
- **Shortcut Menu: Always Enabled**: Displays the Command shortcut menu.
- **Shortcut Menu: Enabled When Command Options Are Present**: Displays the Command shortcut menu only when options are currently available in the command line prompt. In a command prompt, options are enclosed in square brackets. If no options are available, right-clicking is the same as pressing ENTER.

**System variables** AutoCAD stores right-click customization settings in `SHORTCUTMENU`.

In addition to turning the Default, Edit, and Command shortcut menus on and off, you can customize the options that are displayed on them. For example, you can add options to the Edit shortcut menu that are displayed only when circles are selected. For information about customizing shortcut menus, see “Pull-Down and Shortcut Menus,” in chapter 4, “Custom Menus,” in the *Customization Guide*. 
Using Shortcut Menus Outside the Drawing Area

In addition to the drawing area, you can right-click other AutoCAD window areas to display shortcut menus. The following table describes these shortcut menus.

<table>
<thead>
<tr>
<th>Shortcut menu</th>
<th>Access and contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Right-click any toolbar to quickly hide, display, or customize toolbars. Right-click the empty area to the right of the Standard toolbar to display a list of toolbar menu groups (see “Creating and Deleting Toolbars” on page 89).</td>
</tr>
<tr>
<td>Command Line</td>
<td>Right-click the command line or the text window for access to the six most recently issued commands and other options that are useful when working on the command line.</td>
</tr>
<tr>
<td>Dialog Box or Window</td>
<td>Right-click items in most dialog boxes or windows. In general, the shortcut menus for list boxes offer file management commands such as Rename and Delete, and the shortcut menus for edit boxes offer Copy and Paste. Other shortcut menus in dialog boxes may provide context-specific options.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Right-click the coordinate display or any of the buttons on the status bar to quickly toggle drawing aids and lineweight display on and off and modify their settings.</td>
</tr>
<tr>
<td>Model/Layout</td>
<td>Right-click the Model tab or any of the layout tabs in the lower-left corner of the drawing area to display plotting, page setup, and various layout options.</td>
</tr>
</tbody>
</table>

Using Pointing Devices

You control AutoCAD with a pointing device such as a standard mouse, an IntelliMouse®, or a digitizing tablet. You can specify points either by clicking the pointing device or by entering coordinates on the command line. A pointing device, such as a mouse or a digitizing puck, may have a number of buttons. AutoCAD assigns the first 10 buttons automatically, but you can reassign all but the pick button by modifying the menu file (acad.mnu). Button behavior described in the following sections assumes that the acad.mnu file contains the default settings supplied with AutoCAD.
**Mouse**

You can choose options from menus and toolbars by clicking them with your mouse. You also can use the mouse to draw or to select objects on the screen. With a two-button mouse, the left button is the pick button used to specify points on the screen. The right button either displays a shortcut menu or is equivalent to pressing ENTER, depending on your pointer location and the right-click settings. (See “Controlling Default, Edit, and Command Shortcut Menus” on page 60.) Pressing `SHIFT` and right-clicking displays the Object Snap shortcut menu. With a three-button mouse, the middle button either activates real-time panning or displays the Object Snap shortcut menu, depending on the current value of the `MBUTTONPAN` system variable.

**IntelliMouse**

The IntelliMouse is a two-button mouse with a small wheel between the buttons. The left and right buttons behave the same as they do on a standard mouse. You can rotate the wheel by discrete values. You can use the wheel to zoom and pan in your drawing without using any AutoCAD commands.

By default, the zoom factor is set to 10 percent; each increment in the wheel rotation changes the zoom level by 10 percent. The `ZOOMFACTOR` system variable controls the incremental change, whether forward or backward. The higher the number, the smaller the change.

The following table lists the IntelliMouse mouse actions supported in AutoCAD.

<table>
<thead>
<tr>
<th>To ...</th>
<th>Do this ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in or out</td>
<td>Rotate the wheel forward to zoom in, backward to zoom out</td>
</tr>
<tr>
<td>Zoom to drawing extents</td>
<td>Double-click the wheel button</td>
</tr>
<tr>
<td>Pan</td>
<td>Press the wheel button and drag the mouse</td>
</tr>
<tr>
<td>Pan (joystick)</td>
<td>Press CTRL, hold down the wheel button, and drag the mouse</td>
</tr>
<tr>
<td>Display the Object Snap shortcut menu</td>
<td>Change the <code>MBUTTONPAN</code> system variable setting to 0 and click the wheel button</td>
</tr>
</tbody>
</table>
**Tablet**

You can use a digitizing tablet to select frequently used commands, to select an object on the screen, or to simply draw objects. The tablet’s pointing device, which you use to select an object, can be a puck or a stylus. The crosshairs on the screen follow the movement of the pointing device in the drawing area of the tablet. Button 1 is the pick button, which is used to specify points on the screen. Button 2 either displays a shortcut menu or issues ENTER, depending on the pointer location and the right-click settings. (See “Controlling Default, Edit, and Command Shortcut Menus” on page 60.) Pressing SHIFT + button 2 displays the Object Snap shortcut menu, from which you can select object snaps.

You can also use a tablet to digitize drawings by tracing objects into the AutoCAD drawing database with coordinates that relate to the original drawing. For example, if you are working with a printed circuit design that was prepared originally by hand, you can store and edit that drawing in AutoCAD.

To digitize a drawing, calibrate or align the tablet with the paper drawing’s coordinate system. If the paper drawing is too large to fit on the tablet, enter the drawing in pieces, but make sure to align each piece. AutoCAD has a special Tablet input mode. Tablet mode differs from Digitizer mode in that the active area of the tablet coincides with the current display window. In Digitizer mode, an area of the tablet coincides with specific coordinates in your drawing; the portion of your drawing that you are currently viewing is irrelevant. For more information about calibrating tablets, see chapter 5, “Configuring a Digitizer,” in the Installation Guide.

Any command requiring you to select objects with the pointing device works in Tablet mode. For example, to erase an object, start the ERASE command and move the tablet pointing device until the pick box is over the object. For more information about the tablet, see TABLET in the Command Reference.

**Refreshing the Screen Display**

You refresh the display to remove blips or temporary markers that indicate points you have specified. To refresh the drawing display, you can either redraw or regenerate. Because regeneration can take a long time in complex drawings, you will usually redraw. Redrawing cleans up only the display. Regenerating not only cleans up the display, but also updates the drawing database with the screen coordinates for all objects in the drawing.

The database stores information about a drawing’s objects as floating-point values. A floating-point format ensures a high level of precision, but it may
make calculations time-consuming. When AutoCAD regenerates an object, it converts the floating-point database values to the appropriate screen coordinates.

Some commands automatically regenerate the entire drawing and recompute the screen coordinates for all objects. When this happens, AutoCAD displays a message.

**To redraw the screen**
- From the View menu, choose Redraw.
  - **Command line** REDRAW

**To regenerate a drawing**
- From the View menu, choose Regen.
  - **Command line** REGEN

### Saving Drawings

When you are working on a drawing, you should save it frequently. If you want to create a new version of a drawing without affecting the original drawing, you can save it under another name.

**To save a drawing**

1. From the File menu, choose Save.
   - If you previously saved and named the drawing, AutoCAD saves any subsequent changes and redisplays the Command prompt. If you have never saved the drawing, the Save Drawing As dialog box is displayed.
2. In the Save Drawing As dialog box under File Name, enter the new drawing name (the file extension is not required).
3. Choose Save.

You can change the way AutoCAD saves drawing files, including the interval at which AutoCAD automatically saves a drawing.

- **Command line** SAVE saves the drawing. SAVEAS saves a copy of the current drawing under the name you specify.

- **System variables** SAVETIME sets the time interval at which AutoCAD automatically saves your work. RASTERPREVIEW controls whether BMP preview images are saved with the drawing.
Closing Drawings

The CLOSE command closes the active drawing. You can also click the Close button in the upper-right corner of the drawing.

To close a drawing

1. Click the drawing you want to close to make it the active drawing.
2. From the File menu, choose Close.

**NOTE** The CLOSE command is not available when AutoCAD is in Single Document mode.

Exiting AutoCAD

If you saved your most recent changes to all open drawings, you can exit AutoCAD without saving the drawings again. If you have not saved your changes, AutoCAD prompts you to save or discard the changes.

**To exit AutoCAD**

- From the File menu, choose Exit.

  **Command line** QUIT
After you start a drawing, you can change its settings, including drawing units and limits, snap and grid settings, and layer, linetype, and lettering standards. You can also modify the AutoCAD® environment to fit your personal preferences or the needs of a particular project. This chapter describes the drawing settings and AutoCAD options that you can modify.
Setting Drawing Units

Every object you draw is measured in units. You determine the value of the units within AutoCAD before you draw. For example, in one drawing, a unit might equal one millimeter of the real-world object. In another drawing, a unit might equal an inch. You can set the unit type and number of decimal places for object lengths and angles. You can also specify the units for blocks and other content you insert from AutoCAD DesignCenter™ (see chapter 14, “Managing Content with AutoCAD DesignCenter”). Drawing unit settings control how AutoCAD interprets your coordinate and angle entries and how it displays coordinates and units in the drawing and in dialog boxes (see “Setting User Preferences” on page 80).

Setting drawing units does not automatically set units for dimensions (see “Formatting Primary Dimension Units” on page 422). You generally set drawing units and dimension units to the same type and precision, but you can set different values for dimension units.

To format drawing units

1. From the Format menu, choose Units.

2. In the Drawing Units dialog box, set the unit values for your drawing. As you change unit settings, AutoCAD shows examples under Sample Output.

- Under Length, select a unit type and level of precision.
- Under Drawing units for AutoCAD DesignCenter blocks, select the unit that you want AutoCAD to use to scale blocks, images or other content inserted into the drawing. If you do not want AutoCAD to scale inserted content, select Unitless.
Under Angle, select an angle type and precision.

To specify an angle direction, choose Direction, and then select the base angle in the Direction Control dialog box.

The angle direction controls the point from which AutoCAD measures angles and the direction in which they are measured. The default is 0 degrees on the right side of the figure, measured counterclockwise. If you select Other, you can enter an angle, or choose Angle to specify an angle using your pointing device.

Choose OK to exit each dialog box.

**Command line**  
**UNITS**

**System variables**  
AutoCAD stores entries from the Drawing Units dialog box in ANGBASE, ANGDIR, AUNITS, AUPREC, INSUNITS, LUNITS, and LUPREC. AutoCAD stores entries from User Preferences in the Options dialog box in INSUNITSDEFSOURCE to assume source content units setting, and INSUNITSDEFTARGET to assume the target drawing units setting when Insert Units are not defined.

**Setting Grid Limits**

You can set the rectangular boundary, or limits, of the drawing area that is covered by grid dots when the grid is turned on. The grid provides a visual representation of the limits. Setting the limits controls the extent of the display of the grid, and serves as

- A reference tool that marks the area in your drawing on which you’re currently working
- A drawing tool that optionally prevents drawing outside the grid limits
- A plot option that defines an area to be printed
In model space, the limits should encompass the full-scale size of the model. For example, if the object is 100 x 200 mm, you might want to set your limits to represent a slightly larger area.

If you define limits in paper space, the limits boundary usually represents the final sheet size of the paper. Therefore, in paper space, the grid limits should be set to the proper size to contain the entire sheet of paper, including the drawing, dimensions, title blocks, and other information. For example, if you have a sheet of paper that is 210 x 297 mm, you could set decimal units and then specify 0,0 as the lower-left corner and 210,297 as the upper-right corner of the limits.

When paper space is active and either the paper margins or the paper background is displayed, you cannot set the drawing limits with LIMITS. In this case, limits are calculated and set by the layout according to the selected paper size. You can control the display of the paper background and paper margins from the Display tab of the Options dialog box (see OPTIONS).

When you open a new drawing and use either the Quick Setup or Advanced Setup wizard, you set grid limits in model space. The following procedure describes how to set limits once the drawing is open.

To set grid limits

1. From the Format menu, choose Drawing Limits.
2. Specify the lower-left corner of the limits, which corresponds to the lower-left corner of your drawing area. Press ENTER to use the default (0,0).
3. Specify the upper-right corner of the limits, which corresponds to the upper-right corner of your drawing area.
   For example, if the lower-left corner is at 0,0, you can specify a limits area that is 30 units wide and 10 high by entering 30,10.
4. On the status bar, click Grid.
5. From the View menu, choose Zoom ➤ All. The grid shows the area defined by the limits.

Command line LIMITS

System variables LIMMAX stores the upper-right drawing limit for the current space. LIMMIN stores the lower-left drawing limit.
Setting the Grid

The grid is a pattern of dots that extends over the area specified by the limits. Using the grid is similar to placing a sheet of grid paper under a drawing. The grid helps you align objects and visualize the distances between them. You can turn the grid on and off in the middle of another command. The grid is not displayed in the plotted drawing.

If you zoom in or out of your drawing, you might need to adjust grid spacing to be more appropriate for the new magnification.

To turn on the grid and set grid spacing

1. From the Tools menu, choose Drafting Settings.

2. On the Snap and Grid tab of the Drafting Settings dialog box, select Grid On.

3. Enter the value for Grid X Spacing in units.

4. To use the same value for vertical grid spacing, press ENTER. Otherwise, enter a new value for Grid Y Spacing.

5. Choose OK.

To turn the grid on or off, click Grid on the status bar, use the GRID command, press CTRL+G, or press F7.

Command line  DSETTINGS

Shortcut menu  Right-click Grid on the status bar and choose Settings.
Setting Snap Spacing

Snap mode restricts the movement of the crosshairs to intervals that you have defined. When Snap is on, the cursor seems to adhere, or “snap,” to an invisible grid. Snap is useful for specifying precise points with the keyboard or pointing device. You control snap precision by setting the X and Y spacing. Snap has a toggle control and can be turned on or off during another command.

Snap spacing does not have to match grid spacing. For example, you might set a wide grid spacing to be used as a reference but maintain a closer snap spacing for accuracy in specifying points. You also can set the grid spacing to be smaller than the snap spacing.

To turn on Snap mode and set snap spacing

1. From the Tools menu, choose Drafting Settings.
2. On the Snap and Grid tab of the Drafting Settings dialog box, select Snap On.
3. Enter the value for Snap X Spacing in units.
4. To specify the same vertical snap spacing, press ENTER. Otherwise, enter the value for Snap Y Spacing.
5. Under Snap Style & Type, select Rectangular Snap and Grid Snap. (For information about isometric and polar snap options, see “Using Snap Mode with Polar Tracking” on page 166, and “Setting Snap and Grid to Isometric Mode” on page 166.)
6. Choose OK.

To turn Snap mode on and off, click Snap on the status bar, use the SNAP command, press CTRL+B, or press F9.

Command line  DSETTINGS
Shortcut menu  Right-click Snap on the status bar and choose Settings.
Modifying the AutoCAD Environment

You can change many AutoCAD window and drawing environment settings in the Options dialog box. For example, you can change how often AutoCAD automatically saves a drawing to a temporary file, and you can link AutoCAD to directories containing files you use frequently. Experiment with different AutoCAD environment settings until you create the drawing environment that best fits your needs. See OPTIONS in the Command Reference for more information about modifying the AutoCAD environment.

To change AutoCAD options

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose a tab and select the settings that you want to change. The following sections provide information about tabs in the Options dialog box:
   - **Files:** See “Specifying Search Paths, File Names, and File Locations” on page 74.
   - **Display:** See “Configuring the AutoCAD Display” on page 76.
   - **Open and Save:** See “Opening and Saving Your Drawings” on page 77.
   - **Plotting:** See “Controlling Plotting Properties” on page 78.
   - **System:** See “Configuring System Options” on page 79.
   - **User Preferences:** See “Setting User Preferences” on page 80.
   - **Drafting:** See “Setting Drafting Properties” on page 80.
   - **Selection:** See “Changing Selection Options” on page 81.
   - **Profiles:** See “Creating Profiles” on page 82.
3. When you've finished setting options, choose Apply.
4. Choose OK.

**Command line** OPTIONS

**Shortcut menu** With no commands active and no objects selected, right-click in the drawing area and choose Options.
Specifying Search Paths, File Names, and File Locations

The Files tab of the Options dialog box is where you set the search path AutoCAD uses to find support files such as text fonts, drawings, linetypes, and hatch patterns. The working support file search path lists paths from the support file search path that are valid and exist in the current system directory structure (including system network mapping). Using these options helps improve performance when AutoCAD loads these files.

You also can specify the location of temporary files on the Files tab. AutoCAD creates temporary files on disk, and then deletes them when you exit AutoCAD. AutoCAD sets the temporary directory to the location that Microsoft® Windows® uses. If you plan to run AutoCAD from a write-protected directory (for example, if you work on a network or open files on a CD), specify a different location for your temporary files. The directory you specify must not be write-protected, and the drive containing the directory should have sufficient disk space for the temporary files.

If you want to use a custom menu, specify it in the Menu, Help, and Miscellaneous File Names box. The default menu is acad.mnu.
Other search paths, file names, and file locations on the Files tab include

- Device driver file search path
- Project files search path
- Text editor, dictionary, and font file names
- Print file, spooler, and prolog section names (the prolog section of the acad.psf file can be customized to override AutoCAD PostScript code when using PSOUT)
- Printer support file path
- Search path for ObjectARX™ applications
- Automatic-save file location
- Data sources location
- Drawing template file location
- Log file location
- Temporary drawing file location
- Temporary external reference file location
- Texture maps search path

To change a search path

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Files tab.
3. On the Files tab, click the plus sign (+) to the left of the kind of path you want to change.
4. Select the path you want to change.
5. Choose Browse, and then search drives and directories until you find the one you want.
6. Select the drive and directory you want to use, and then choose OK.

**Command line**  OPTIONS

**Shortcut menu**  With no commands active and no objects selected, right-click in the drawing area and choose Options.

### Configuring the AutoCAD Display

After you install AutoCAD, you usually do not need to perform any additional configuration tasks on the display, because AutoCAD uses a default display. You can, however, customize the AutoCAD display by using the options on the Display tab in the Options dialog box. You can change the color and font AutoCAD uses and specify a number of other settings.

You can also use the Display tab in the Options dialog box to set layout options. **Layouts** create paper space views for your drawing. You can create multiple layouts and design different floating viewport configurations for each layout. On the Display tab you can specify layout properties; for example, you can display margins or a paper background in a layout. These options help you to see what your drawing looks like when plotted.
Other settings that you can change on the Display tab include

- Display properties of AutoCAD window elements
- Resolution settings that affect rendering quality
- Size of AutoCAD crosshairs
- Display settings that affect performance
- Fading intensity control for references being edited in place

See OPTIONS in the Command Reference. Also, see “Working with Layouts” on page 517.

**Opening and Saving Your Drawings**

The Open and Save tab in the Options dialog box controls settings that relate to opening and saving drawing files. If you turn on the Automatic Save option, AutoCAD saves your drawing at specified time intervals. Drawings are saved to the temporary directory specified as the Automatic Save File Location on the Files tab.

**NOTE** AutoCAD saves files in AutoCAD 2000 format automatically, even if you saved the drawing in the format of an earlier AutoCAD release. This prevents you from losing any AutoCAD 2000 data during your editing session.
Other settings that you can change on the Open and Save tab include

- Maintaining of log files
- Saving of drawing preview image
- Cyclic Redundancy Checking (CRC) error-checking behavior
- Creating of backup drawings
- Behavior of external references
- Behaviors of ObjectARX applications and custom objects

See OPTIONS in the Command Reference.

**Controlling Plotting Properties**

Use the Plotting tab in the Options dialog box to set plotting options. You can specify general plotting controls such as the default plotting device, plot styles, and plot style behavior. A plot style is a collection of property settings that can be applied to different objects in the drawing.

Other settings that you can change on the Plotting tab include

- Plotters and plotter configurations
- System warnings related to plotting
- Plotting behavior of OLE objects
- Plot style tables

See OPTIONS in the Command Reference. Also, see “Working with Layouts” on page 517 and chapter 16, “Plotting Your Drawings.”
Configuring System Options

Use the System tab in the Options dialog box to set the general AutoCAD system settings. For example, by default you can work with multiple documents in one session, but you can change AutoCAD to Single Document mode by selecting Single Drawing Compatibility Mode under General Options.

After you install AutoCAD, you usually do not need to perform additional configuration tasks for the mouse or digitizer, because AutoCAD uses the current system pointing device. However, you can change the current pointing device and control whether AutoCAD accepts input from a digitizer only or from both a digitizer and a mouse.

Other settings that you can change on the System tab include

- Use of long symbol names
- Startup dialog box display
- Behavior during user input errors
- LISP file-loading behavior
- OLE scale dialog box behavior
- Warning message display
- Database connectivity behavior
- 3D graphics display properties

See OPTIONS in the Command Reference.
Setting User Preferences

By using the User Preferences tab in the Options dialog box, you can set up your drawing environment according to the way you work best. You can customize settings for shortcut menus and set display properties for hyperlinks in your drawing.

Other settings that you can change on the User Preferences tab include

- Windows standard behavior
- AutoCAD DesignCenter preferences
- Object sorting methods
- Priority for coordinate data entry
- Lineweight settings
- Hyperlink preferences

See OPTIONS in the Command Reference.

Setting Drafting Properties

The Drafting tab in the Options dialog box contains options that control settings of several AutoCAD drawing aids. For example, AutoSnap™ helps you locate exact points on an object. AutoTrack™ helps you draw objects at specific angles or with specific relationships to other objects in the drawing.
Changing Selection Options

The Selection tab in the Options dialog box controls the AutoCAD selection tools and object selection methods. You can control the size of the AutoCAD pickbox and specify selection modes that you want turned on while you draw. For example, the Implied Windowing option creates a selection window when you click in the drawing area. If you select Use Shift to Add to Selection, you can expand an object selection set by holding down SHIFT while you select the new objects.
Other settings that you can change on the Selection tab include

- Grip behavior and properties
- Press and drag selection
- Noun/verb selection
- Object grouping selection
- Associative hatch selection

See OPTIONS in the *Command Reference*.

### Creating Profiles

You can use the Profiles tab in the Options dialog box to create and save your drawing environment settings as a profile. If you share your workstation with other users who use the same login name, you can restore your options by making the profile current. You can also create and save profiles to use with different projects. By default, AutoCAD stores your current options in a profile named UNNAMED PROFILE. AutoCAD displays the current profile name, as well as the current drawing name, in the Options dialog box.

The profile information is stored in the system registry and can be saved to a text file (an ARG file). AutoCAD organizes essential data and maintains changes in the registry as necessary.

Once you save a profile, you can export or import the ARG file to and from different computers. If you make changes to your current profile during an AutoCAD session and you want to save those changes in the ARG file, you must export the profile. When you export the profile with the current profile name, AutoCAD updates the ARG file with the new settings. You can import the profile again into AutoCAD to update your profile settings.

**To make a profile current**

1. From the Tools menu, choose Options.
2. In the Options dialog box, choose the Profiles tab.
On the Profiles tab, select the profile you want to make current.

Choose Set Current. Then choose OK.

**Command line**  OPTIONS

**Shortcut menu**  With no commands active and no objects selected, right-click in the drawing area and choose Options.

You can also initiate a specific profile before starting AutoCAD by using a command line switch.

**To make a profile current before starting AutoCAD**

1 On the Windows desktop, right-click the AutoCAD icon to display the shortcut menu.

2 Choose Properties from the shortcut menu.

3 In the AutoCAD Properties dialog box, choose the Shortcut tab.
4 Under Target, enter `/p currentprofile` after the current target directory. For example, to make the profile User12 current, enter the following in Target:
"c:\acad2000\acad.exe`/p user12"

5 Choose OK to exit the dialog box.
The profile name you enter is the current profile each time you start AutoCAD.

For more information about profiles, see OPTIONS in the Command Reference. For more information about command line switches, see chapter 4, “Configuring and Optimizing AutoCAD” in the Installation Guide.

## Optimizing Performance

To optimize AutoCAD performance while working in a drawing, you can change certain settings in the Options dialog box. Keep in mind, however, that your drawing file size and system hardware play significant roles in AutoCAD performance.

The following settings on the Display tab in the Options dialog box affect performance:

- **Arc and Circle Smoothness**: Set to a low value such as 100 for drawing and increase the value for rendering to optimize performance. The valid range is 1 through 20,000. When you increase the value, rendered objects are smoother; however, AutoCAD requires more time to regenerate, pan, and zoom.

- **Segments in a Polyline Curve**: Set to a low value such as 4 to optimize performance. The higher the number of line segments, the more time is required to regenerate the drawing.

- **Rendered Object Smoothness**: Set to 1 or less to optimize performance. The valid range is 0.01 through 10. When you increase the value, display performance decreases and rendering time increases.

- **Contour Lines per Surface**: Set to a low value such as 4 to optimize performance. The valid range is 0 through 2047. When you increase the value, display performance decreases and rendering time increases.

- **Pan and Zoom with Raster Image**: Clear to optimize performance. During panning and zooming, AutoCAD displays only the frame of the raster image instead of the entire raster image.

- **Highlight Raster Image Frame Only**: Select to optimize performance. Only the frame of the raster image, as opposed to the entire raster image, is highlighted when it is selected.

- **True Color Raster Images and Rendering**: Clear to optimize performance. When AutoCAD displays images at optimum quality, regeneration time increases significantly. To improve performance while working in a
drawing, change the system display setting to decrease the number of colors.

- **Apply Solid Fill**: Clear to optimize performance. Drawing regeneration time decreases because multilines, traces, solids, all hatches (including solid fill), and wide polylines are displayed as outlines, with no solid fill.
- **Show Text Boundary Frame Only**: Select to optimize performance. Drawing regeneration time decreases because a boundary box is displayed instead of the actual text.
- **Show Silhouettes in Wireframe**: Clear to optimize performance. When silhouette curves of body objects are not displayed, drawing regeneration time decreases.

The following settings on the Open and Save tab in the Options dialog box affect performance:

- **Save As**: Set to an AutoCAD Drawing format to optimize performance. When you save an AutoCAD file to any DXF™ file format, performance decreases when the drawing is saved.
- **Incremental Save Percentage**: Set to 50 to optimize performance. AutoCAD saves only the changed drawing information until the amount of changed space is equal to the value set in this option. When AutoCAD performs a full save, the entire drawing is saved. When this option is set to 0, AutoCAD performs a full save every time. If you set this option to a low value, such as 20 or less, performance significantly decreases during a save.
- **Demand Load Xrefs**: Set to Enabled to optimize performance. This option loads only the parts of the referenced drawing that are needed to regenerate the current drawing. Use this option when working with clipped xrefs that contain a layer or spatial index.

The following setting on the System tab in the Options dialog box affects performance:

- **Store Links Index in Drawing File**: Select to optimize performance during Link Select operations. Clear this option if you want to reduce the drawing file size or if you want to optimize opening drawings containing database tables.

The following setting on the Selection tab in the Options dialog box affects performance:

- **Enable Grips**: Clear to optimize performance. A grip is a small square displayed on an object after you select it. When you select this option, drawing file size increases and regeneration time increases.

See OPTIONS in the *Command Reference*.  

Modifying the AutoCAD Environment | 85
Viewing and Updating Drawing Properties

You can track your drawings more easily by assigning properties to them. Drawing properties are details that help you identify the drawing, including title, author, subject, and keywords to identify the model or other important information. You can also store hyperlink addresses or directory paths and ten custom properties with your drawings.

To define drawing properties
1. From the File menu, choose Drawing Properties.
2. In the Drawing Properties dialog box, enter property information on the following tabs:
   - **Summary tab:** You can enter the drawing title, subject, author, keywords, comments, and a hyperlink base. Keywords help you search for drawings sharing a common property. For example, you can add the keyword “Autodesk” to all your drawing files, then search for all drawing files with that key word. For a hyperlink base you can specify an Internet address or a path to a folder on a network drive.

![Drawing Properties dialog box](image)

   - **Custom tab:** You can enter up to ten custom properties. Specify the names of the custom fields in the column on the left, and the value for each custom field in the column on the right.
Choose OK to exit the dialog boxes.

**Command line**  
**DWGPROPS**

You can use the Drawing Properties dialog box to view drawing information maintained by AutoCAD.

- **General tab**: Displays the drawing type, location, size, and other information. The information is derived from the operating system. All fields are read-only. However, if you access file properties through Windows Explorer, the attributes options are made available by the operating system.
- **Statistics tab**: Displays data such as file size and the dates files were created and last modified. You can search for all files created at a certain time, for example, after March 3, 1998, or files last modified yesterday.

**NOTE**  Properties entered in the Drawing Properties dialog box are not associated with the drawing until you save the drawing.

The Created, Modified, and Total Editing Time values are stored in the TDCREATE, TDINDWG, and TDUPDATE system variables.
Modifying Toolbars

You can change the size of toolbar buttons and reposition, add, or delete toolbar buttons. You can also change the toolbar name and turn tooltips on and off.

To modify a toolbar

1. From the View menu, choose Toolbars.
2. If the toolbar you want to modify is not displayed, select it in the Toolbars dialog box.
3. Choose Customize.
   ![Customize Toolbars dialog box]
4. While the Customize Toolbars dialog box is displayed, you can modify any displayed toolbar as follows:
   - Drag toolbar buttons right or left to reposition them.
   - Create spaces by dragging a button to the right or left edge of the button beside it, but not past the middle.
- Remove toolbar buttons by dragging them off the toolbar.
- Add buttons to toolbars by dragging them from the Customize Toolbars dialog box to the toolbar. Change the Categories selection to display the buttons you want to add.
- Drag buttons from one toolbar to another, or press CTRL while you drag to copy the toolbar button to another toolbar.

5 Choose Close to exit the dialog boxes.

**Command line** TOOLBAR

**Shortcut menu** Right-click a toolbar and choose Customize.

To rename a toolbar
1 From the View menu, choose Toolbars.
2 In the Toolbars dialog box, select the toolbar name, and then choose Properties.
3 In the Toolbar Properties dialog box, enter a new name.
4 To change the text displayed on the status line, enter new text at Help, and then choose Apply.
5 In the Toolbars dialog box, choose Close.

To display tooltips
1 From the View menu, choose Toolbars.
2 In the Toolbars dialog box, select Show ToolTips and choose Close.

**System variables** TOOLTIPS turns tooltips on and off.

To change the size of buttons
1 From the View menu, choose Toolbars.
2 In the Toolbars dialog box, select Large Buttons and choose Close.

**Creating and Deleting Toolbars**

To create a new toolbar, you first create an empty toolbar, and then drag buttons onto the new toolbar from the Customize Toolbars dialog box or from other toolbars.
To create a toolbar
1. From the View menu, choose Toolbars.
2. In the Toolbars dialog box, choose New.

   ![New Toolbar dialog box]

   3. In the New Toolbar dialog box, specify a name for the toolbar.
   4. Under Menu Group, specify the menu group to associate with the toolbar.
   The Toolbars dialog box lists all available toolbars. The menu group determines the file to which your toolbar configuration is saved.
   5. Choose OK.
   6. In the Toolbars dialog box, choose Close.

   The new, empty toolbar is displayed. You can now add tools to the toolbar (see “Modifying Toolbars” on page 88). You can also create new toolbars by dragging a toolbar button from the Customize Toolbars dialog box to the AutoCAD window. A new toolbar is displayed with the button. For more information, see chapter 4, “Custom Menus,” in the Customization Guide.

   Command line    TOOLBAR
   Shortcut menu    Right-click a toolbar and choose Customize.

To delete a toolbar
1. From the View menu, choose Toolbars.
2. In the Toolbars dialog box, select the toolbar and then choose Delete.
3. Choose OK.

   **WARNING!** You cannot undo this action. AutoCAD prompts you to confirm.

### Creating and Editing Toolbar Buttons

After you create a toolbar, you can add buttons supplied with AutoCAD, or you can create your own by modifying existing buttons. Under one button icon, you can create or modify a set of buttons called a flyout. You can customize the appearance of buttons to suit your needs.
Creating a Toolbar Button

AutoCAD commands are organized into categories in the Customize Toolbars dialog box. You can select a category to display a set of icons that represent a group of commands. AutoCAD also provides blank icons that you can assign to any command or macro.

Most commands begin with ^C^C to cancel a command that may be running and display the Command prompt. An underscore (_) enables commands to work on international versions of AutoCAD. An apostrophe (’) enables the command to work in conjunction with another command. If you associate a series of commands with a button, separate them with semicolons or spaces. You create button macros the same way you create menu macros. For more information about entering commands in macros, see chapter 4, “Custom Menus,” in the Customization Guide.

To create a button

1 From the View menu, choose Toolbars.
2 Right-click any button on an existing toolbar to display the Button Properties dialog box.
3 Enter a new name for the button.
4 In Help, enter the explanatory text you want displayed on the status line.
5 To associate a command with the button, enter the command under Macro.
6 Under Button Icon, select an icon for the button.
7 To modify the button icon, choose Edit.
8 After making any changes to the icon, choose Save or Save As, or choose Close to close the Button Editor dialog box.
9 To apply the new button and properties to the toolbar, choose Apply in the Button Properties dialog box. Then choose Close to close the Toolbars dialog box. To add the newly created button to a toolbar, see “Modifying Toolbars” on page 88.
Changing the Command Assigned to a Button

In addition to changing a button associated with a command, you can change a command associated with a button.

To change a command
1. From the View menu, choose Toolbars.
2. Right-click the button you want to change.
3. In the Button Properties dialog box, edit the command information under Macro to specify a new command for the button.
4. Choose Apply.
5. In the Toolbars dialog box, choose Close.

Command line  TOOLBAR
Shortcut menu  Right-click a toolbar and choose Customize.

Creating a Flyout

A flyout is a set of buttons nested under a single flyout button on a toolbar. Flyout buttons are defined by a black triangle in the lower-right corner. To create a flyout, you create the flyout button and associate an existing toolbar with it.

To create a flyout
1. From the View menu, choose Toolbars.
2. In the Toolbars dialog box, choose Customize.
3. In the Customize Toolbars dialog box under Categories, select Custom.
4. Drag the flyout icon (a small black triangle) from the Customize Toolbars dialog box to the destination toolbar.
   If you don’t have a destination toolbar, AutoCAD creates one when you drop the button anywhere except on another toolbar.
5. Right-click the newly created flyout button.
6. In the Flyout Properties dialog box under Associated Toolbar, select the toolbar to associate with the flyout.
NOTE Always create a toolbar before you create a flyout. If you don’t associate a toolbar with the flyout button, AutoCAD issues a warning beep when you select the flyout button.

7 Under Button Icon, select an icon for the flyout. You can modify the icon by choosing Edit to display the Button Editor. See the following section, “Editing Button Icons.”

8 To display the icon you specified, do one of the following:

- Select Show This Button’s Icon: Displays the icon you specified for the flyout. When you click the flyout, AutoCAD starts the command represented by the first button on the toolbar you associated with this flyout.
- Clear Show This Button’s Icon: Displays the first button on the toolbar you associated with this flyout until you use a different button from the flyout, when that button is displayed.

9 Choose Apply, and then close the dialog boxes.

**Editing Button Icons**

AutoCAD provides standard button icons to start commands. You can create custom icons to run custom macros. You can modify an existing icon or create your own. AutoCAD saves buttons as BMP (bitmap) files.

**To edit or create a flyout icon**

1 From the View menu, choose Toolbars.
2 Right-click a flyout on an existing toolbar to display the Flyout Properties dialog box.
3 In the Flyout Properties dialog box under Button Icon, select an icon and then choose Edit.
The Button Editor dialog box provides a close-up view of the button icon. If you select Grid, AutoCAD divides the view into a grid. Each grid box represents one pixel. The Button Editor dialog box displays the button icon at its actual size in the upper-left corner.

You can open an existing button using Open.

4 Use the Pencil, Line, Circle, and Erase tools to create or edit the button icon. To add color, select a color from the color palette.

- **Pencil button:** Edits one pixel at a time in the selected color. You can drag the pointing device to edit several pixels at once.
- **Line button:** Creates lines in the selected color.
- **Circle button:** Creates circles in the selected color.
- **Erase button:** Sets pixels to the background color when you drag the pointing device. Double-click the Erase button to set all pixels to the background color.

5 To save the customized button, choose Save As, specify a file name, and choose Save. To overwrite the original button, choose Save.

6 Choose Close.

7 In the Flyout Properties dialog box, choose Apply.

8 In the Toolbars dialog box, choose Close.
Using Commands and System Variables

AutoCAD® commands give you enormous power. Spending time learning how AutoCAD commands and system variables work and how to use them will make you more efficient and productive.

This chapter describes the methods for starting commands, working with command prompts, modifying the command window, and changing system variable settings.
Working with AutoCAD Commands

Nearly every action you perform in AutoCAD is based on a command. You use commands to tell AutoCAD the actions you want it to perform, and AutoCAD responds with command prompts. Command prompts tell you the status of an action, or they give you options from which you must choose to complete a command.

You can use any of the following to start commands:

- AutoCAD menus
- Toolbars
- Shortcut menus
- Command line
- Accelerator keys

You can start any command by entering its full name at the Command prompt. Some commands also have abbreviated names. For example, instead of entering `circle` to start the CIRCLE command, you can enter `c`. Abbreviated command names are called aliases. For a list of command aliases, see appendix A, “Command Aliases,” in the Command Reference.

Regardless of how you start a command, the command prompts flow in the same way. AutoCAD either displays prompts on the command line or displays a dialog box. The prompt format is

```
current instruction or [options] <current value>:
```

The current instruction begins with one of four verbs. The verb communicates the action you can perform, as shown in the following table.

<table>
<thead>
<tr>
<th>Verb</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>Use the pointing device to select objects, or use another object selection method. See “Selecting Objects” on page 234.</td>
<td>Select objects:</td>
</tr>
<tr>
<td>Enter</td>
<td>Enter a value on the command line.</td>
<td>Enter an option to change [Invisible/Constant/Verify/Preset] &lt;done&gt;:</td>
</tr>
<tr>
<td>Specify</td>
<td>Select a point on the screen or enter a value, such as a coordinate, on the command line.</td>
<td>Specify center point for circle or [3Point/2Point/Tangent tangent radius]:</td>
</tr>
<tr>
<td>Digitize</td>
<td>Select a point on a digitizing tablet (TABLET command only).</td>
<td>Digitize point #1:</td>
</tr>
</tbody>
</table>
Commands often have options, which are displayed within brackets. To choose an option, enter the option’s capitalized letter (uppercase or lowercase) on the command line. If an option is preceded by a number, such as the CIRCLE command 3Point option, enter the number and capitalized letter: \texttt{3P}.

To execute commands or enter command options, you can

- Press \texttt{ENTER}
- Press \texttt{SPACEBAR}
- Right-click in the drawing area and choose \texttt{Enter} from the shortcut menu

\textbf{NOTE} You can set options for the pointing device so that right-clicking has the same effect as pressing \texttt{ENTER}. See “Setting User Preferences” on page 80.

\section*{Working with the Command Window}

The command window is a dockable window in which you enter commands and AutoCAD displays prompts and messages. For most commands, a command window showing two or three lines of previous prompts, called the \textit{command history}, is sufficient. For commands with text output, such as \texttt{LIST}, you may need to make the command window larger, or press \texttt{F2} to display the text window.

By default, the command window is docked at the bottom of the AutoCAD window and displays three lines of text. If text that is entered becomes longer than the width of the command line, the command window is displayed in front of the command line to show the full text of the line.

The command window displays the command state and history for the current drawing. If you have multiple drawings open and switch from one to another, the command state and history changes to show the state and history of the current drawing.

You can resize the window vertically by selecting the \textit{splitter bar} with your pointing device and dragging it up or down. The splitter bar is located on the top edge of the command window when the window is docked at the bottom of the AutoCAD window and on the bottom edge when it’s docked at the top.
To undock the command window

- Select any part of the command window border and drag it away from the docking region. Drop the window to make it a floating window. You can move the floating command window anywhere on the screen and change its width and height with the pointing device.

![Floating command window](image)

To dock the command window

- Drag the command window to the top or bottom docking regions of the AutoCAD window. To dock the command window at the bottom of the AutoCAD window, release the pointing device while the cursor is directly over the status bar.

If you right-click in the command window or text window, AutoCAD displays a shortcut menu from which you can access the six most recently used commands, copy selected text or the entire command history, paste text, and access the Options dialog box.

You can use BACKSPACE or DEL to delete command line text, and you can copy text from the text window and paste it on the command line (see “Copying Text to the Command Line” on page 100). The following table lists keys you can use to navigate or change text in the command window.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>LEFT ARROW</td>
<td>Moves cursor back (to the left)</td>
</tr>
<tr>
<td>RIGHT ARROW</td>
<td>Moves cursor forward (to the right)</td>
</tr>
<tr>
<td>UP ARROW</td>
<td>Displays the previous line in the command history</td>
</tr>
<tr>
<td>DOWN ARROW</td>
<td>Displays the next line in the command history</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>Moves to the previous window</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>Moves to the next window</td>
</tr>
<tr>
<td>HOME</td>
<td>Places cursor at the beginning of the line</td>
</tr>
<tr>
<td>END</td>
<td>Places cursor at the end of the line</td>
</tr>
</tbody>
</table>
Repeating Commands

You can repeat AutoCAD commands using one of several methods.

To repeat the last command
- Press ENTER or SPACEBAR, or right-click in the drawing area and choose Repeat.

To repeat one of the last six commands
1 Right-click in the command window or text window.
2 From the shortcut menu, choose Recent Commands, then choose one of the six most recently used commands.

To repeat the same command multiple times
1 At the Command prompt, enter `multiple`.
2 At the next prompt, enter the command you want to repeat.
   AutoCAD repeats this command until you press ESC.

Canceling Commands

You can cancel any command by pressing ESC, the standard key to cancel actions in Windows programs. You can change the cancel key to CTRL+C, which was used to cancel commands in previous AutoCAD releases.

To change the cancel key
1 From the Tools menu, choose Options.
2 In the Options dialog box, choose the User Preferences tab.
   For information about undoing previous actions, see “Correcting Mistakes” on page 104.
Working with the Text Window

The text window is a floating window in which you enter commands and view command prompts and messages. The command window is convenient for viewing the command history for the current AutoCAD session. The contents of the text window are read-only and cannot be modified. However, you can copy the command history and paste it on the command line or to other applications such as word processors. Use the text window to view lengthy output from information commands such as LIST, which displays detailed information about objects.

To display or hide the text window

- Press F2. You can click the window icon in the title bar to display the Window menu, which you can use to move, size, minimize, maximize, or hide the text window.

You can view the entire command history for the current drawing in the text window. To navigate to command text, use the window's scroll bar or use the command window navigation keys, such as HOME, PAGE UP, and PAGE DOWN.

Copying Text to the Command Line

Although command window text is read-only, you can copy command window text (or text from other sources) and paste it on the command line to repeat previous actions or re-enter previously entered values.
Highlight the text to be copied with your pointing device or with the keys shown in the following table.

<table>
<thead>
<tr>
<th>Keys</th>
<th>Select text from ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>SHIFT+RIGHT ARROW</td>
<td>Cursor position to the right</td>
</tr>
<tr>
<td>SHIFT+LEFT ARROW</td>
<td>Cursor position to the left</td>
</tr>
<tr>
<td>SHIFT+END</td>
<td>Cursor to the end of the line</td>
</tr>
<tr>
<td>SHIFT+HOME</td>
<td>Cursor to the beginning of the line</td>
</tr>
<tr>
<td>CTRL+SHIFT+END</td>
<td>Cursor to the end of the window</td>
</tr>
<tr>
<td>CTRL+SHIFT+HOME</td>
<td>Cursor to the beginning of the window</td>
</tr>
<tr>
<td>CTRL+SHIFT+PAGE UP</td>
<td>Cursor through the preceding screen of text</td>
</tr>
<tr>
<td>CTRL+SHIFT+PAGE DOWN</td>
<td>Cursor through the next screen of text</td>
</tr>
</tbody>
</table>

To copy text from the text window to the command line

1. If the text window is not displayed, press F2 to display it.
2. Select the text you want to copy.
3. Right-click in the command window or text window and choose Paste to Command Line.
   AutoCAD copies the text to the Clipboard and pastes it on the command line. After you press ENTER, AutoCAD executes the commands in sequence, like a script. You can also use CTRL+C and CTRL+V to copy and paste text.

**Related** The COPYHIST command copies all the text in the command history to the Clipboard.

The command history displays user-input lines that contain spaces (such as AutoLISP expressions) and command options that accept text strings (such as GROUP descriptions or ATTDEF attribute values). AutoCAD interprets any space on the command line as a line terminator unless it is part of an AutoLISP command (enclosed in parentheses), part of a text string, or part of a name, such as a block or layer name.
Using Commands Transparently

You can use many commands transparently; that is, you can enter them on the command line while another command is active. Most commands that you use transparently change drawing settings or turn on drawing aids such as SNAP, GRID, or ZOOM.

To use a command transparently, enter an apostrophe (') before entering the command at any prompt. On the command line, double angle brackets (>>) precede prompts for transparent commands. After you complete the transparent command, the original command resumes. The following example turns on the grid and sets it to one-unit intervals while you are drawing a line.

Command: line
From point: ‘grid
>>Grid spacing (X) or ON/OFF/Snap/Aspect <0.000>: 1
Resuming LINE command
From point: Continue drawing the line

You can use almost any command transparently if it does not select objects, create new objects, cause regenerations, or end the drawing session. (There are a few other commands, such as 3DORBIT, that you cannot use transparently.) Changes made in dialog boxes opened transparently do not take effect until you execute the interrupted command. Similarly, if you reset a system variable transparently, the new value may not take effect until you start the next command.

NOTE UNDO will undo the command and any transparent commands completed while the command was active.

Switching from Dialog Box to Command Line

You can use some commands both on the command line and in a dialog box. In many cases, you can enter a hyphen before the command to suppress the dialog box and display prompts on the command line instead. For example, entering `layer` on the command line displays the Layer Properties Manager, in which you can define layer properties. Entering `-layer` on the command line displays the equivalent command line options for defining layer properties.
NOTE  Slight differences may exist between the options in the dialog box and those available on the command line.

The FILEDIA system variable controls the display of dialog boxes that read and write files. If you prefer to enter file names on the command line, set FILEDIA to off. If FILEDIA is set to off and you want to use the dialog box, enter a ~ (tilde) at the file name prompt.

Using Scripts to Run Commands

A script is a series of AutoCAD commands in a text file that can be used to carry out a task. With scripts, you can run several commands in succession. For example, you can script a series of AutoCAD commands for overnight batch processing. You also can create a group of drawing display files known as slides and then write a script that displays them in a slide show. To create a script, make a text file with commands and command options entered exactly as you would enter them on the command line. For information about creating scripts, see “Command Scripts” in chapter 6, “Programming Interfaces,” in the Customization Guide.

Using System Variables

System variables control many AutoCAD functions and many aspects of the design environment. System variables control how many commands work. System variables also turn drawing modes (such as Snap and Grid) on or off, set default scales for hatch patterns, and store information about the current drawing and AutoCAD configuration.

System variables have abbreviated names that are usually 6–10 characters long. Many system variables have simple on or off settings. For example, for GRIDMODE, entering 0, off, or false turns the grid off; entering 1, on, or true turns the grid on. Other system variables store numbers or text: LIMMAX stores the upper-right drawing limits, for example, 12.0000,9.000; DWGNAME is a read-only variable that stores the current drawing file name.

You generally change system variables through dialog box entries. However, you can change system variables directly on the command line, which is quicker in certain situations.
To change system variables on the command line

1. At the Command prompt, enter the system variable name and press ENTER.
2. Enter the new system variable value and press ENTER.

The following example shows GRIDMODE changed on the command line.

Command: `gridmode`
Enter new value for GRIDMODE <0>: 1

You can examine or change the setting of a system variable while using another command. However, if you change the value, the new value may not take effect until the interrupted command ends.

You can also use the SETVAR command to list or change system variable values. This command is particularly useful for listing the values of some or all system variables at any time. Entering `?`, then `*` at the SETVAR prompt displays all system variables and their values.

For a complete list of all the system variables in AutoCAD, see appendix B, “System Variables,” in the Command Reference.

Correcting Mistakes

You can use several methods to undo your most recent action or actions. The simplest is to use the UNDO command to undo a single action.

The UNDO and REDO commands maintain a separate list of actions for each open drawing. For example, you can create a line in drawing A, switch to drawing B and draw a circle, and then switch back to drawing A and undo the line.

To undo the most recent action

- From the Edit menu, choose Undo.
- **Command line** UNDO
- **Shortcut menu** With no commands active and no objects selected, right-click in the drawing area and choose Undo.
- **Related** REDO restores what you have just undone.
To undo a specific number of actions

1. At the Command prompt, enter `undo`.
2. On the command line, enter the number of actions to undo.
   For example, to undo the last ten actions, enter `10`. AutoCAD displays the commands or system variable settings that were undone.

Use the Mark option of UNDO to mark an action as you work. You can then use the Back option of UNDO to undo all activities that occurred after the marked action. You also can use the Begin and End options of UNDO to undo actions you've defined as a group.

To redo the last UNDO action, you can use the REDO command.

To redo an action

- From the Edit menu, choose Redo.

  **Command line** REDO

  **Shortcut menu** With no commands active and no objects selected, right-click in the drawing area and choose Redo.

---

**Learning Commands and System Variables**

This *User's Guide* covers many AutoCAD commands and command options, but it does not cover all of them. Use the *Command Reference* to find commands alphabetically and to learn about each command option in detail. The *Command Reference* provides additional information about using commands and also provides a complete listing of AutoCAD system variables in appendix B, “System Variables.”

To access the *Command Reference*

1. From the Help menu, choose AutoCAD Help Topics.
2. In Help topics, click the *Command Reference* book icon.

**NOTE** You can order printed versions of the *Command Reference* from your Autodesk dealer or reseller.